How to free up space in kali?


#1

Im running re4son kernel 4.9 and it seems that i can’t find the correct commands that work on this raspberry kali version.
I’m trying to clean up cache and redundant file’s.
I tried to install bleachbit and it appears to have installed but when i used the given command to run it, it says command not found. I did unpack and install.
I seen a few posts talking about moving file’s out of the root directory and resizing the root but if i can’t even get simple commands to work, i don’t want to mess around with root.
Root was used up 98% i did manage to get apt-get clean and it’s now used up 87%. Still not good enough.
Im trying to solve a problem of my pi freezing while in aurodump-ng which btw shows no ap what so ever even after running for 30 minutes so i need to find out what’s going wrong.


#2

what’s the size of the sd card and can you run the command
df -h
to tell us the size of used space


#3

Yes sure. That’s the command i used to check it in the first place.
My micro is a 32g

                  Size.       Used.   Avail.   Use%   mount

/dev/root. 7.2g. 5.9g. 927m. 87% /
Devtmpfs. 460m. 0. 460m. 0% /dev
Tmpfs. 464m. 0. 464m. 0% /shm
Tmpfs. 464m. 13m. 452m. 3% /run
Tmpfs. 5.0m. 0. 5.0m. 0% /lock
Tmpfs. 464m. 0. 464m. 0% sys/fs
Tmpfs. 93m. 12k. 93m. 1% run/user0


#4

Try:
Sudo apt-get autoremove

I did that on a few Ubuntu machines that has been heavily used and had their hard drives filled until the kernal complained. I ran that and it freed up 5gb. It basically nremoves outdated packages and whatnot. Those machines are still running to this day and they haven’t complained about space. I have ran it on my Pi and freed up a some space on occasion when I needed it


#5

Thank you. I’ll give it a try.


#6

Man I like that command. I was installing some drivers and my laptop slowed down and was like “Low disk space” today. Ran that and boom I freed up 647MB.