KiMax BS-U35WF - using Windows Only

I just got the case and I have 3TB hard Drive ready for it.
I used parted to make a GPT drive of 2.7TB - checked it on RPi and it mounted OK.
But when I used it - I see that it shows 0B - and I am not sure how to create users?

I believe that it will not work only after it recognized the space on the DRIVE, correct?
It say that this case support up to 6TB - how did they do it?
Did they used something different to format the disk?
I want to be able to have the 3TB drive working in the case - how can i do that?
Please assist - thanks

I have this on My Pi
sudo fdisk -l /dev/sda
Disk /dev/sda: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6735766C-FDB1-4755-97BB-542D4B4EF8CB

Device Start End Sectors Size Type
/dev/sda1 2048 5860532223 5860530176 2.7T Linux filesystem

Model: WDC WD30 EZRZ-00Z5HB0 (scsi)
Disk /dev/sda: 3.00TB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 0.00TB 3.00TB 3.00TB primary

Can anyone assist?? Am I doing something wrong? thanks

Hi All.
Problem solved…
BTW Don, it can be NTFS drive and I use it like that - Basically that is how I made it work after all.
There is a VERY SIMPLE way to format the disk and it is straight forward :slight_smile:
After installing the HDD in the case USE the USB cable to connect to a Windows PC. at the management creat and NTFS Drive. format and that is it. took me less then 3 min to get the drive to work and show the 3TB storage.

Since I was fixed on the EXT4 that what gave me a HARD time - But after I decided to go with NTFS - it works and I can use the BT as well.

I have a question…
How can I manage users???
Can I have more then the admin user?
I also managed to connect from my Android BUT I used the admin and the new password I gave it.

Any one was able to create another user?

1 Like

interesting… i might have to try that later

I would love to know how…

tl;dr - I can’t access partitions on the silly thing using SMB.

I bought this thing to perform the simplest of tasks; I need a simple NAS that will show up on all the Windows machines on the internal network without using passwords; I’ll use the Tomato router to firewall connections outside the LAN. I figured this would be simple; change the IP to a static one within my LAN (, the range used by my first wired router back in the late 1980’s), turn on file sharing (samba, I assumed), and poof - all computers on the LAN would immediately see the thing.

When it showed up the other day, however, I discovered it wants to be my main router (never gonna happen), and I should hook it up to the Chinese servers (really never gonna happen), but does not want to actually share the files on the drive…

I prepared a 2T hard drive using NTFS copying the files on a production drive, installed it to the BS-U35WF, fired it up, and…nothing is working the way I’d expect. If I use USB I can easily work with the hard drive. If I connect with an Ethernet cable, I get nuthin’. If I connect with WiFi (of course killing my connection to the Tomato router) I see (eventually) two shares with two additional “guest” shares. I can’t open ANY of them, since Windows tells me access is denied, either the username or password is incorrect. Yes, I tried all of the user names and passwords I could find; sticker on the bottom, listed in “manual” for settings page, “Admin,” “Administrator,” et al in combinations ad nausium. (When checking the drive details on the main settings page, it tells me the main partition is NTFS and the other tiny one, which I’m suspecting is actually free non-partitioned space, is ext4.)

I’ve screwed with the IPs, LAN/WAN settings, and every other setting I could think of, and have been making frequent use of the paper-clip reset button to start over; but after spending the better part of two days screwing with this thing, I’m no farther ahead. I’ve watched some YouTube videos, and my version of the firmware (1.7.0, and I can’t find any other downloadable stock firmware anywhere) doesn’t seem to have some of the binding settings seen in some of the videos. I found a total of one reference of a build of OpenWRT running on it, but am reluctant to go that route without stock firmware to flash in an emergency. I downloaded (and will be watching a little later) Don’s video and a few others I haven’t watched yet, but I’m wondering if anyone has any idea what I can do to get this silly thing to share the drive properly? I am relatively fearless thanks to the reset button, and so will cheerfully try anything. I can provide screen dumps and photos if requested. The drive is actually a backup of a production drive (it was supposed to replace the existing drive), so I can screw with that, too, costing me nothing more than having to re-copy the production drive.

Or did I spend $40 for a $10 USB case, which is thus far the only thing I’ve been able to use it for successfully?

Me too, Does anyone have a solution?

IF still having problems connecting.
Regarding the username and password - is admin and the password set on the web interface. If not changed use the kimax default password with user as admin.

To use the disk - I just used the USB 3 connection and partitioned it on windows 8.1 (that is what I have) and afterwards I connected it to the router and it shows ad a disk under the static IP I gave it. that is exactly what i said first time.

Hope it works.

Important - can’t use USB and Ethernet together - when using the Ethernet DISCONNECT the USB cable.

1 Like

Thans! I have just solved The problem was HD formatted GPT. I converted it iin MBR and it works. Kimax doesn’t read GPT

Okay this is my experience with this box. Firmware version: 1.7.9

Username and password: it has only two users by default and no new user can be added.

  • user-1: “guest” password : “12345678” <- password can not be changed, anyway I never used this user.
  • user-2: “admin” password : default -> “kimax” or you can change from web page ( factory default) by connecting to its internal WiFi AP named Something like “KIMAX-xxxx”. With wired LAN you can use same after getting assigned IP address from your router.

I used the user “admin” to mount and access these shared partitions in my desktop PC or mobiles.

Disk: I tried using 4TB GPT disk with all NTFS ( total 3 partitions). It worked as is where is, I moved from my PC to this box. No juggling required. I am accessing these shared partitions on Windows 8.1u1 PC, Raspberry Pi as music player and Android Mobile phone. username: admin, password: or default “kimax”

Access: For the data transfer, you can either use USB or connected LAN (WLAN/Ethernet) not both simultaneously. Preference from device is given to USB if connected.

Tips and Tricks: example: I connected wired LAN (Ethernet cable with IP Address reserved on my router, say Then through web UI I connected to that IP Address ( non default now, using my Web browser from PC. Changed the WiFi setting to relay existing WiFi. This makes me access files through same IP ‘’. I removed that WiFI external antenna, (It has another WiFi antenna internally pasted to the plastic front face plate). Now my data access through wired LAN at ‘’ gives me read from NAS speed 7-8MB per second and Write to NAS with 2.5 MB per second. Useful for streaming constantly within that range. FLAC file needs ~1.2-1.7MB/Sec. Basically my router is sitting in the middle from NAS to end End Device. It could be like router -> NAS -> device

I will be experimenting with its internal WiFi AP if that improves speed further or not. I feel wired LAN is better option than WiFi.

1 Like

Bought this thing few weeks ago. Since then cannot get it working. Thought the problem is with the item and meantime bought another piece. Same result
Two different PCs do not detect the box via USB at all. Via ethernet cable I can see the drive, can see the the size (500GB) but cannot do any changes within folders because of permissions. I cannot change those permissions either.
Please help

if anybody needs KIMAX -H1 BS-U35WF 1.7.5 firmware version and apks, download from here:

i installed the firmware KIMAX -H1 BS-U35WF 1.7.5 firmware version successfully from the above link however the usual passwords to login no longer work. do u have any ideas on what the default password is for that firmware?

I use the password “kimax” and works ok.

I do. Bought my device from them. Working fine.

My Arlo Camera System Hub (VMB4540) has a USB port for connecting an external drive for local recording. I’m wondering if I connected the BS-U35WF USB 3 port to my Arlo Hub whether the Arlo Hub would recognize it as a USB drive?
The Arlo Hub requires the external drive to be formatted in FAT32. Will the BS-U35WF work with FAT32?
Will the BS-U35WF allow me to access files on its drive via Ethernet or WiFi while the USB 3 port is connected to a host (the Arlo Hub)?
My purpose in this configuration is better remote access to local Arlo recordings.
Thanks in advance for your help!
I have copied this post to a new post: Kimax BS-U35WF on Arlo Camera Hub?
Please respond this the new post, thanks!

Hi, I need your help…

I bought this Blueendless Kimax U35WF and what I wanted to do was stream music and videos to my Raspberry Pi, but the speeds are so slow that I just can’t whatch, the stream stops every 15 seconds.

Someone has a good experience streaming?
Do you have any idea how to solve this low speed? If I change the firmware the speed gets better?

Thank you very much

I finally got it to work as you described it. In the end I needed port forwarding.

  1. Scanned all services using advanced port scanner while connected to its wifi. Found that it had samba at a few ports, ftp and http server.
  2. Configured port forwarding between its internal network (192.168.169) and the externnal ip on my main network for each of those ports.

I tried creating a static route and also changing the 169 network to match my main network but failed at that.

just to add to this as i fought this battle all night last night. sometimes the cache holds a wrong hard coded username. Clear cache or use a different browser. kimax should work.

I fought the same issue. turns out that the username is hardcoded in the javascript files. when you upgrade firmware, it keeps the cached file with the wrong username. Try a different browser or clear cache. or hard code the javascript username to admin and password kimax using the inspection console on chrome.