LattePanda Alpha Gigabit Ethernet reduced speed?


#1

Quick question to the happy owners: what link speed you get from the Alpha’s LAN port? Windows or Mac. Mine is 100Mbit max.
The RTL8111F should connect imho at 1 Gigabit.
(I have not yet tried the new Clover 2.1 set.)


#2

Let me ask it differently: what link speed LED you see in your LAN switch, where the LattePanda Alpha is connected: — 100Base TX or 1000 Base TX ?


#3

I get gigabit speeds on windows. Haven’t tried Mac OS on the Lattepanda. If it’s an issue with Mac OS a driver would need to be made for gigabit speeds. (Currently messing with an eGPU and not an NVME drive)


#4

Thanks - much appreciated. Mine Panda must have had then a hardware or bios issue as I can not get Gigabit link even on Windows 10. Realtek drivers did not help.


#5

Not even on Windows 10? That sounds like a problem. Unless your switch is 10/100 or there are some slower devices connectected to the switch. It would be a hardware bug.


#6

I tried 3 cables and 4 switch vendors. I even bypassed the speed negotiation enforcing 1000base-T from the switch port menu. (Then no link at all). I read somewhere 1000base-T uses more pairs than the 100base-TX wiring. Could be indeed a hw defect on one pin or so…


#7

It might be a faulty port or something wrong with your controller. Thats the only problem I can think of.


#8

Yes - Indeed my friend! I am proud to say this is fixed now :grin:. The Gigabit works and my Alpha is healthy! It turned out that there were so called “cold junctions” at pin 5 and pin 7 of the ethernet connector on the PCB (i.e. bad soldering at the factory).
Here is the story:
Initially, I discovered no noise at pin 5 using a digital oscilloscope and then started studying how such a port is typically being constructed. Apparently there are four pairs of Ethernet wires, each pair has a dedicated transformer coil in the integrated magnetics chip PSF-2447 (differential design). The transformers provide isolation to the sensitive electronic drivers. Each coil has an additional center connection, all these center points are joined together and via a capacitor connected to the PCB ground. Electrically, for DC, all the 8 Ethernet pins are connected together via those low-resistance coils.
Bottom line:
If anyone suspect similar HW problem, then it seems pretty safe to disconnect completely the board, and then just use a LAN patchcord cable and a basic ohm-meter (preferably with tone) and check the connectivity across all the pins 1…8 in the RJ-45 plug at hand. There should be also a connection from RJ-45 to any of PSF-2447’s pins 13-24. (never touch pins 1-12, as these lay on the sensitive side of the circuit.)
I was lucky, that with help of a small soldering iron and a magnifying glass the problem was easily solvable.

One disappointment was thou, that I had written a prior email to the Dfrobot techsupport, asking for help, and nobody ever dared to respond.
Hope this post was useful.


#9

So it was a hardware problem. Hopefully I don’t have any solder joints that go bad. Sounds tedious to go fix that.