LattePanda Alpha Hackintosh 4k support [HALF SUCCESS]


#1

Hi guys,

I’d like to share my attempt to output 4k resolution from LP Alpha.
Short story, half succeeded. I saw true HiDPI 1080p and 4k from the screen.
The reason for half success is that I lost GPU hardware acceleration. Also, the LP Alpha didn’t recognize the name, vendor, and product id of the monitor.

I did a lot of experiments so I’m not crystal clear what affects what, but here’s what I think it will work for you guys too.

(1) Build your own Lilu.kext, WhateverGreen.kext, and AppleALC.kext

(2) Launch CloverConfigurator. Mount EFI. Read config.plist from EFI/CLOVER
Devices->IntelGFX: 0x591E8086
(I’m not sure this is totally necessary, but just in case)

(3) Graphics ig-platform-id: 0x12345678
This is the important part. If you haven’t updated Lilu and other kexts, you would probably have kernel panic or hangs.

(4) In the mounted EFI partition, copy EFI/CLOVER/kexts/Other to EFI/CLOVER/kexts/Other.bak
Do the same for config.plist (before you modify, I hope you have the original one in USB thumb drive)
If something goes wrong you can restore each backup to original.
Now delete the kexts from EFI partition that have the same name as the ones you built from step(1), copy the newly built kexts to EFI partiton.

(5) reboot!

There are many things I tried, but I believe these are the ones for 4k support.
Let me know if it’s working. If it’s not I’ll upload the whole cofig.plist.

I’m still trying to get full 4k support with graphics acceleration.
Cheers

I know hackintosh is not an exact science, the generation and device id, platform id of current MacPanda are wrong. I managed to get them right. Currently it is set to Skylake(lilucpu=8) instead of Kabylake(lilucpu=9). Device ID is 0x591E0000 and ig-platform-id is also 0x591E0000. You need to do framebuffer patch for this.
and the tool ‘Hackingtool’ is very useful to check these.
(https://www.insanelymac.com/forum/topic/335018-hackintool-v182/)

However, this hasn’t affect anything yet. I corrected them in a hope that it will fix the 4k issue. It hasn’t, but still, I think it’s better to correct them for Lilu and WhateverGreen or other kexts correctly recognize the system and GPU to support it.


By the way, for kenel panic/hang, the Clover boot options -v and debug=0x100 helps. the latter stops the system when kernel panicked instead of immediate reboot.


#2

Thanks for sharing your promising interim results - much appreciated! I am also very interested to get the 4k. I will try to experiment based on your input and post here in case of any progress.


#3

Hylo can you post your clover config.plist I changed the AAPL,ig-platform-id in 05001C59
and the device id in. 1C590000 and added enable-hdmi20 01000000


#4

http://bit.ly/2I7EFE8

Thanks Olo!

Hi BluDread.
The above link is my config.plist at that time.
May I ask you why you used 591C? The correct platform and device id are 591E.
(I’m terribly sorry there’s a typo in my original post. it should be 591E8086 instead of 581E8086)
I suggest you secure recovery mechanism before you tinker with config.plist.
You may not be able to boot again.
My recovery method is booting to Windows(on the same SSD) and using TransMac, restoring erroneous config.plist to a sane one.

Anyways, I also tried enable-hdmi20 and mac-pixel-clock patch but no joy yet.
It seems like Framebuffer patch doesn’t work except ig-platform-id and device id…


#5

yeah but I was thinking and thinkering with my hack panda :wink: and in the hackintool it says its for intel UHD Graphics 615 and not for intel HD Graphics 615 I thought it needed UHD to be able to display in 4K resolution instead of HD witch is 1080p and it also worked that’s what I was thinking. but now with the DSDT of yours I can thinker even more hihihi I have booted your config.plist but for me and my alpha it didn’t worked that well can you trie the one I have

my config.plist
https://drive.google.com/file/d/1MA3X_sO7T3BiQRhvg4_TbEG1uYcWHvyo/view?usp=sharing

and this is my DSDT.aml I use for audio
https://drive.google.com/file/d/1gD-SL-R5hwIax2N3B1IEpgj6F9wHvJQT/view?usp=sharing

it’s just for experimental use

My recovery method is booting in clover and select a working copy a previously made :wink:

now we can say succes :wink:

hi guys this is my clover directory .

https://drive.google.com/drive/folders/1mgZgmsJEpA7-U6xzHFOwFsNaKbC2EtgR?usp=sharing

once I booted in to Mac OS I also used FixEDID version2.3.2 to create a override folder for my screen where I added the max resolution of my screen . otherwise I couldn’t select the resolution .

here is the link to FixEDID


#6

Sorry for late reply. I have been busy these days. And my setup has broken so I can’t even bring up 4k without graphics acceleration. (Ssd change, clover update, …)

I lost 4k, hdmi audio, low powet sleep mode, …
:frowning:

It looks like you succeeded?! Could you share your method?


#7

Do you mind sharing your CLOVER directory? I tried your config.plist. Using HDMI output maximum resolution stays at 1080p, using DP->HDMI converter LP boots into black screen (TV does not see any signal when desktop should appear). I copied your .aml file and a new WhatseverGreen and Lilu.
By the way: Can you play iTunes movies? I always get HDCP error.

Thanks, Rudi


#8

@BluDread: Your CLOVER folder does not work for me. It boots and afterwards I used FixEDID. However, higher resilutions do not appear in my list and if I boot using DP->HDMI I will get blank screen…
Any ideas?


#9

It didn’t work for me too. I didn’t have to fix EDID though. And it’s from Feb 15, there’s a chance it might not be the latest one.


#10

yes in the clover config file under devices properties PciRoot(0)/Pci(0x02,0) change framebuffer-con2-type data to 00040000 for boot using the DP to HDMI convertor and after you used the FixEDID to generate the overrides map did you changed the file inside the map with the correct value for the screen resolution because adding it under FixEDID is not enough FixEDID adds the resolution like this in the file

AAAPAAAACHAAAAABACAAAA==

you need to cut of the end so it becomes this

AAAPAAAACHAAAAAB==

afterwards the resolutions should become available if not you can try to run this command in the terminal

sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true

the only thing is that clover won’t boot in 4K


#11

Sorry, it’s till not working. I tried changing connector type on both con1 and con2 (I’m using con1 according to Hackingtool).

BlueDread, How did you get EDID value on Graphics section in config.plist?

P.S. folks who are trying to use FixEDID first get EDID.bin using DarwinDump
I’m using SwitchResX so I don’t need it.


#12

Thank you for being so patient. I used DarwinDump to generate an EDID file and used FixEDID to generate the resolutions required. Is the string AAAPAAAACHAAAAABACAAAA== within the newly generated EDID-file? Where to need to place the new EDID file and the additional files (one kext and one DISPLAY directory)?
Soory for asking again: Can you play iTunes movies (HDCP issue on my LP)?
Thanks again for beeing that patience with me.
Rudi


#13

the string AAAPAAAACHAAAAABACAAAA== is within the newly generated file inside the Display directory you can open it with Xcode and cut of the end so it becomes AAAPAAAACHAAAAAB=
afterwards you need to place the Display directory in your /System/Library/Displays/content/resources/overrides folder then it should show up after reboot in your screenconfiguration or an app I use RDM 2.2 the previous setResX I don’t use SwitchResX
the EDID File created I also didn’t use and the kext I also didn’t use. but you can keep them for a while on the desktop for later use if you want to inject the EDID for instance in your clover config file

Can you play iTunes movies (HDCP issue on my LP)?

I don’t know I seldom use iTunes movies but on this side everything till now seems to work vlc works Kodi works


#14

Hi hylo con1 is also my connection I use, it is HDMI in my case I left it like this 00080000 otherwise the audio wouldn’t work over HDMI .
do you mean in the clover config.plist I use Xcode
open up EDID.bin with hex fiend and copy the hex code in to the value field for the EDID injection it the Field starts with AAPL00,override-no-connect


#15

Using your CLOVER with changed -conX entries and the new DISPLAY-directory I can switch resolution now to 3840x2160. However, picture quality is very bad and TV is telling me that I am still at 1080p. So it looks like its just kind of a calculated resolution but definitely not UHD.