LP Alpha 64 shutdown issue


#1

My youngest kid was playing Sims on the MacPanda version of the LP ALPHA 864 when it suddenly turned off.
We restarted, but it happened again soon after I looked into my account on it.
The weather here has been very warm the past few days.
Also, I don’t have an enclosure for the LP. My office, where the LP resides has a slight breeze.
The standoffs I used for the LP BSC are plastic. It sits on a glass table.
I created a power adapter setup made by a YouTuber, it is 12v, 5amp DC. Has worked for many months and hours without an issue. I hope to continue using it again.
I sent an email to tech support at DFROBOT.
The first recommendation was to unplug everything and remove the battery for last least 3 hours (reinstall), then use the power supply they provided with it.
Well, I am typing this to you from it right now.

It seems like maybe static electricity caused the issue? And maybe the fact that the LP Alpha was very warm to the touch?

It looks like I might need a grounded enclosure, or a static electricity resistant / dissipating case going forward? I would like to improve cooling though.


#2

The lattepanda runs very hot overall. I recommend going into the BIOS and changing the start temperure of the fan to the lowest setting so it starts at a lower temperature for the fan. I have a thermal camera and during operation the VRM and other power delivery parts of the board get quite hot. I saw 85 degree C or higher on the power delivery portion. They are rated to run at high temperatures but it still gets super hot. If you could get a 120 Mm fan to bow over the board it would cool it quite a bit. In my case I put an eGPU with mine so I set it on an ATX power supply and the fan kept the lattepanda way cooler. I never have had any stability issues with that as the constant airflow keeps it 20C cooler. It could be grounding issues possibly but maybe that power supply you are using might be the culprit. Try using the original one for a bit to see if the problems go away. Undervolting the lattepanda helped my temps especially when I didn’t have any other active cooling besides the CPU fan.


#3

Well, recently it started to suddenly reboot. I thought it was an issue with static, as I contacted DFRobot, and that was the recommendation.
Turn off and disconnect power.
Remove battery, wait 5 minutes, and then reinstall battery.
Restart
It worked for a few days, but now won’t boot into Windows or MacOs, just some CLI.
Anyway, I’m thinking about tossing this little unstable SBC. I was going to use it for my shop, but it has become so unreliable that it isn’t worth the time to tinker to get it to work reliably. I wanted to both tinker with the arduino in my shop and also use it to control other machines and electrical devices. But, it requires too much involvement and doesn’t seem to work at all now.


#4

I somehow think that the flash seems to be bad on it. If it seems to work intermittently and the issues keep getting worse I would think that the flash is bad. Who knows if it’s that but it sounds like a dead unit. Well if you don’t want it I would be happy to try to fix it. I have a working one that I could use to help diagnose problems. If I got it working I could ship it back.


#5

Somehow it just booted up. I began with starting in the BIOS. Made sure the SSD with the preferred Os was visible, then started up as usual.
I’ll check on modifying fan start temperatures.
Thanks for the advice.


#6

Do a filesystem check when you get into the OS. Also run memtest x86 to test the RAM too to see it it’s acting up.

Are you booting from an external USB to an SSD or do you have the internal storage (if equipped)? I had issues booting off of an USB HDD. I use my NVME for an eGPU so I don’t have any other option. Apparently some enclosures work better than others.


#7

Thank you for the advice.
I’m not sure if Memtest x86 will run on MacOS.
A file system check, no problem, I’ll do one today.
There is a thought that occurred to me, maybe disconnecting the power supply and removing the battery for a long time effects the BIOS settings? I’m still learning about how motherboards work.


#8

Also, NVME has Os and a few apps on it.


#9

Ya it would reset the BIOS. Sometimes it can cause issues as it can’t find a boot device. (Shouldn’t happen) you can run memtest x86 off of an USB stick if you want. I believe the ultimate boot disk has it installed. (Flash the ISO to a USB stick). Basically if I were you I would just start testing things and ruling them out.