macOS Catalina 10.15

Does anyone know if it will be possible to install macOS Catalina 10.15 on LattePanda, I did various tests but I failed, can someone help me?

Same here. Maybe it requires new version of clover

I can’t even start it, I’ve already updated clover, kext and .efi files

what kext did you update?

Only those that can be updated via Clover (Lilu, WhateverGreen, AppleALC, FakeSMC, USBInjectAll)

I also tried to update everything else but it doesn’t work, I don’t know where the problem is, try it

did you update the 10.15 folder?

The 10.15 folder was created by updating Clover and it is empty, I left the kext in the Other folder

1 Like

The only idea that came to my mind would be to compare the config.plist attached to this article:
How to Create a macOS Catalina Public Beta Installation USB with the config.plist that used to work with Panda.

it’s possible that some configs has to be changed for the config.plist i also had to manually create a custom plist for the gpu. that might be effecting the 10.15

If we can install it we could do all the necessary tests,there is no way to understand at what point it stops, at least we focus on that

I don’t think the problem is the Kext because even without it doesn’t start (Clover R4982)




I succeeded, macOS Catalina 10.15 Developer Preview 3/4 runs on LattePanda with Clover R4982-R5028 :yum:
macOS Catalina Developer Preview 3
macOS Catalina Developer Preview 4
EFI folder files (08-02-2019 update to Clover R5028)
Clover_v2.4k_r4982
Clover_v2.5k_r5028
Works with all kext and other updated files :grinning:
Fast guide:
Create a USB stick with Catalina Developer preview 3/4 + Clover R4982/R5028
Replace the EFI partition files with the attached ones
LattePanda Catalina Photo-Video-Files (Updated 08-02-2019)
It is possible to perform a clean installation or upgrade from Mojave to Catalina without formatting.
Untested 4K monitor, i used a full HD monitor (1920x1080p)
How to Install MacOS Catalina Beta on APFS Volume to Dual Boot with Mojave

09-09-2019 Problem with updating to Developer preview 5/6/7 and Public Beta 4/5/6, installation loading time and update installation time too long, I haven’t been able to update yet

2 Likes

wow!!! i can’t wait to test this. do you mind if i make a video?

1 Like

No problem but maybe it’s better to wait until September when Catalina will officially come out :+1:
I need your help, i can’t start the Developer Beta 5/6/7 anymore, i’m using Clover R5050 with Developer Beta 4, i am attaching the files of the EFI folder i used updated to today (08-20-2019) that you can download from here
The only files I can’t update are the ones that end with -64.efi, I don’t know where to look for new ones, downloading them from Clover they have a different name that doesn’t end with -64.efi, try to check yourself if I’ve done everything correctly

I have the Catalina released version running in a VM, which is great!

I subsequently tried the installation guides I could find here (and a mix thereof) but was not able to boot from USB into the installer.
The USB installer was a bit different than described in the posts. With the latest version of clover I did have to disable SIP in recovery mode first (terminal: csrutil disable) and after a reboot run it.

Did anybody succeed?
If so, would you be so kind to make the clover and kext files available?

i have catalina running
https://drive.google.com/drive/folders/1S-VOaszjX_3vyvBIohsWBRNNd30tiMKF?usp=sharing
is my shared clover

4 Likes

Thanks for sharing @BluDread for your response.
Great to hear you got it running on the LattePanda.
Which Clover version did you use, and which LP version?

I’ve been reading so many threads and posts, watching youtube videos etc., I want to rule out as much things as possible.
I’ll download your files and give it a go before this weekend.

i installed clover beta revision 5096 my LattePanda Alpha is with first m3-7Y30 processor

1 Like

Thank you @BluDread for sharing your Clover folder.
I’m attempting a clean install and have create the latest version of the Catalina installer on a 32GB USB disk. The target 512GB Toshiba drive that is formatted during the installation process (GUID, Journaled).
With 2 minutes remaining before completing the first round of installation (after partition creation), the process stops for a reboot with the following log lines:

Oct 18 22:18:51 MacBook opendirectoryd[212]: [session] ODSessionRelease completed
Oct 18 22:18:54 MacBook osishelperd[637]: brtool exited success
Oct 18 22:18:54 MacBook osinstallersetupd[620]: Stash mode set to none, will skip.
Oct 18 22:18:54 MacBook osishelperd[637]: Boot chime muted
Oct 18 22:18:54 MacBook InstallAssistant[618]: Client of osinstallersetupd is not running in an Aqua session, forcing reboot.
Oct 18 22:18:54 MacBook osinstallersetupd[620]: Client side reboot failed, forcing reboot.
However, after reboot while starting from the newly created partition, the LP does not successfully continue the installation process. I will capture a log file from screen and post in a new message.

Aqua is the graphical user interface and visual theme of Apple’s macOS operating system. It was originally based on the theme of water, with droplet-like components and a liberal use of reflection effects and translucency.