Upgrading from 10.14 to current makes boot problem

Upgrading from Mojave 10.14 to current version didn’t happen smoothly, and still hasn’t it won’t fully boot up. Just stalls at the progress screen.
Any suggestions?

Same problem here, looking now for a solution to repair the situation …

I was able to use the USB stick with Mojave on it to reinstall mojave (10.14) over the failed version. Until a process comes to light, I’m staying on this release.
My accounts and software were present and functional.

I found the same trouble with my LattePanda
At first i try 10.14.3 and everything was fine. On 25 of march apple releases 10.14.4 update that i installed… And after that i can’t start update process because of freezing progress bar (
I try to make new usb flash with fresh 10.14.4 installer but it’s won’t boot and also freez at progress bar and then reboots.

The solution is:
1 Create a usb drive with macOS 10.14.3 and use a new clover files (https://github.com/novaspirit/macpanda/releases) and install macOS.
2 When the installation is complete restore from Time Machine backup (optional).
3 Download and upgrade to macOS 10.14.4.
On my LattePanda works well, tested this night.

I try to install macOS Developer Beta 10.14.5 and works!

1 Like

Hi! Wich version of LattePanda Clover you used? I tryed it with 2.2.1 and had that problem. For now i have clean install of 10.14.3 on new ssd and will try to update one more time… Let’s see how far we go)

2.2.1 (Clover_v2.4k_r4895)

1 Like

I just successfully upgraded from 10.14.3 to 10.14.4 without any Time Machine reinstallation, etc. Only the old pendrive with Mojave Install was needed. (Actually the Mojave Installer itself is not needed).
Note the file “ApfsDriverLoader-64.efi” from the Novaspirit Clover package 2.2.1 is being detected as “unsafe” or “malicious.1cf413” by two security heuristic/AI antimalware engines: Cylance and Cybereason (via VirusTotal.com).
Therefore I decided to download the latest Clover r4910 from the SourceForge.net by myself.
The Clover version 4910 does not trigger any alarms, including the mentioned suspicious file.

Here is my sequence on how to safely upgrade from 10.14.3:

  1. Download the latest Clover package from https://sourceforge.net/projects/cloverefiboot/. Check the MD5 and check for viruses on VirusTotal.com.
  2. Insert your old MojaveInstall pendrive you had used for your MacPanda installation. I assume some old Clover version was installed there - it will get upgraded in the next steps. The Mojave version does not matter because the installer will not be started.
  3. Download the Novaspirit Clover package 2.2.1 from the Github: https://github.com/novaspirit/macpanda/releases.
  4. Navigate to the folder …/CLOVER/drivers64UEFI of the downloaded package, note all the names of the .efi drivers needed. Do NOT use those files.
  5. Install the Clover r4910 to the EFI partition of the pendrive in a similar way like described in the initial MacPanda Youtube video from Don, but with the following difference: please select for installation (or upgrade) all the 12 drivers you identified in the point 4 above. (I think these were from two installer menu sub-branches). De-select unwanted drivers.
  6. Open the Pendrive’s EFI partition (visible as mounted after the Clover installation).
  7. Copy all .kext files from Dons Clover package 2.2.1 (from folder CLOVER/kexts/Other) to the corresponding folder of the EFI on the Pendrive. Copy also the main config.plist from the CLOVER directory. This should be sufficient, as all the Clover GUI Themes etc. files should be already present in the EFI in the Pendrive.
  8. Reboot to BIOS. Select in BIOS the pendrive to boot from. Now reboot from the pendrive. Check if you can see the Clover r4910 (instead of the old version) and if you can safely start now your main MacPanda OS. (Do not start the old Mojave Installer). If everything works - you have now an upgraded working Clover configuration on the EFI Partition of your pendrive.
  9. Assuming you booted from the Clover 4910 to your OS from your main drive: Please open the terminal window. Check available partitions: $ diskutil list, then copy the EFI partition from pendrive to the EFI partition on your main drive. In my case this was: $ sudo dd if=/dev/disk2s1 of=/dev/disk0s1
  10. Unmount and remove the pendrive. Reboot from the main drive. You should have the upgraded Clover 4910 and all working Okay, as per your tests executed in the point 8 above.

Thats it! Now your Macpanda is ready for the upgrade to 10.14.4 (or 10.14.5 beta) via the system preferences.
Happy upgrading!

2 Likes

Solved my poblem. After updating all kexts and clover r4919 update installs and everything works!

Next step, try to install a clean copy of macOS 10.14.4 with clover r4910/r4919.
I try to update to macOS 10.14.5 Developer beta and work.

Hey Olo, thanks for having taken the time to write down these steps.

I’ve just followed them and everything is working fine now, my previous Mojave installation has been updated to Clover 4920 (latest version at this time), and after that i have been able to update my installation to Mojave 10.14.4 (despite a few weird reboot in the process - not sure if all of them were expected…).

edit : screenshots added for clarity

1 Like

Last night I tried to install macOS 10.14.4 with Clover 4920 and it runs (clean installation) and it is possible to upgrade to macOS 10.14.5 Beta, for those who only want to upgrade from 10.14.3 to 10.14.4 just reinstall an updated clover copy.

You did well to scan with the antivirus, I confirm the presence of the malware in versions 2.1 and 2.1.1.
Searching on the internet I found another ApfsDriverLoader-64.efi file updated and free of viruses but I haven’t tried it yet.
I found it on https://github.com/athlonreg/Clover_Build/blob/master/drivers64UEFI/ApfsDriverLoader-64.efi

You should just have to reuse the one provided in the CLOVER distribution on sourceforge : https://sourceforge.net/projects/cloverefiboot/files/latest/download

I tried to install Clover 4925 + macOS 10.14.4 + ApfsDriverLoader-64.efi (virus free) and it works fine.
Now let’s wait for MacOS 10.14.5 to come out, I’ve tried until beta 3 and it works fine.
If we also find updated kext we can do everything ourselves.

Tnx SRG! Thanks to your pictures and independent confirmation it became quite a nice upgrade guide :grinning:.

Hey Gnappo, any confirmation about 10.14.5 FINAL on your side ? Just to know if it’s an easy and out-of-the-box installation or if clover still needs to be upgraded.

I just updated from MacOS 10.14.4 to 10.14.5 without problems (Clover R4925)

Has anyone been able to get this to work with a clean install of 10.14.5? I followed all the steps outlined by Olo, but mine just says “Boot installer from” instead of the HD and then boot loops over an over again.

You can try creating a USB stick with macOS 10.14.5 and updated clover (R4925 or higher) following the same procedure described in the video

1 Like